httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Walsham <pe...@axomic.com>
Subject Re: Can't make spool bucket + apreqXXXXXX temp files - Windows & 2.08
Date Mon, 23 Apr 2007 11:44:06 GMT

Hi Randy,

Thanks for your speedy response, much appreciated.

I've just re-installed libapreq2 on one machine as you suggested and it 
seems to have fixed both problems. The machine was experiencing both 
problems before the re-install.


Installed from:
http://theoryx5.uwinnipeg.ca/ppms/libapreq2.ppd

Windows Server 2003
Service Pack 1 build 3790
AMD Athlon 64 3000+ 2.00GHz
Apache    - 2.2.4
mod_perl2 - 2.0.3
Libapreq2 - 2.08
Perl      - 5.8.8


I will do further tests on some other machines tomorrow.

If you let me know when you have any future releases to test let me know 
and I would be happy to help.

Many thanks

Pete



Randy Kobes wrote:
> On Thu, 19 Apr 2007, Peter Walsham wrote:
> 
>> I have two problems and I don't know if they are related. I see there 
>> has been some previous discussions of the problems I have been 
>> encountering, but as there aren't solutions currently I thought I 
>> would post details on them.
> 
> Thanks - you're right that this is still a problem ...
> 
>> Both problems involve using Apache2::Upload on Windows. They always 
>> occur on the 4 machines I've tested on (3x Windows Server 2003 and 1x 
>> XP Pro). I'm using libapreq2 2.08 (see bottom for more specs).
>>
>> Both problems make Apache2::Upload unusable on Windows in a production 
>> environment.
>>
>> ============================================================
>> Problem 1 - Temp files are always left in c:/WINDOWS/Temp
>> ============================================================
>>
>> Temp files are always left in c:/WINDOWS/Temp until shutdown and 
>> cannot be removed through perl or explorer
> 
>> ============================================================
>> Problem 2 - A large proportion of uploads fail (maybe 20-50%)
>> ============================================================
>>
>> A large proportion of uploads fail (maybe 20-50%) and produce errors 
>> such as:
>>
>> "$param->upload_tempname($req): can't make spool bucket"
>> or
>> "(OS 5)Access is denied.  : apreq_brigade_concat failed; TempDir 
>> problem?"
>>
>> This problem seems to occur slightly more with larger files, but it is 
>> not deterministic. Repeated tries with the same file will eventually 
>> result in success, but sometime take 20 retries. I have mainly been 
>> testing with images, JPGs etc. Multiple upload request in any one 
>> second seem to increase the chance of failure.
> 
> The fact that this isn't an easily reproduceable problem
> makes it difficult to track down. Assuming you got
> the libapreq2 package through ppm via
>   http://theoryx5.uwinnipeg.ca/ppms/
> would you mind testing out the current libapreq2
> package? It contains a change that has helped at
> least one other person with a similar problem.
> The version hasn't changed, so you may have to
> uninstall libapreq2 first, and also, stop Apache,
> so that the mod_apreq2.so Apache module can get
> installed. Thanks.
> 

--
OpenAsset - Image Management for Architects, Designers & Engineers
Axomic Ltd
338 City Road
London EC1V 2PY
t: +44 (0)20 7239 8287
m: +44 (0)7812 122418
http://www.axomic.com

The information contained in this message is confidential and should not
be disclosed to any third party whether or not you are the intended
addressee indicated in the message. Any views or opinions presented are
solely those of the author and do not necessarily represent those of
Axomic Ltd. If you are not the intended recipient, be advised that you
have received this email in error and that any use, dissemination,
printing, forwarding or copying of this e mail is strictly prohibited.

Mime
View raw message