httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Gimenez <ggime...@free.fr>
Subject [Fwd: libapreq2: apreq_body doesn't work as expected when body like "a=1&=&c=3" is passed]
Date Sun, 21 Jan 2007 22:59:10 GMT
Hi there !

There is no critical problem with apreq (IMHO). And actualy, it do the 
job very well. But I noticed a small issue you maybe can fix.

Here's a copy of the bugreport(407780) I sent to debian maintainer

-------8<----------------------------8<------------------------------

Package: libapreq2
Version: 2.08-4
Severity: normal


Hi folks,

There is a problem with the apreq_body function.

When I submit a form with malformed input (ie fields without name like
{input type="text" name="" value=""} ) all others parameters in the form
are missed by apreq_body and resulting apr_table_t is empty.

Best regards - Guillaume

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-686
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)

Versions of packages libapreq2 depends on:
ii  libapr1  1.2.7-8.2                       The Apache Portable Runtime Librar
ii  libaprut 1.2.7+dfsg-2                    The Apache Portable Runtime Utilit
ii  libc6    2.3.6.ds1-8                     GNU C Library: Shared libraries
ii  libuuid1 1.39+1.40-WIP-2006.11.14+dfsg-1 universally unique id library

Versions of packages libapreq2 recommends:
ii  libapache2-mod-apreq2         2.08-4     generic Apache request library - A

-- no debconf information



Mime
View raw message