httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Franky Braem <f.br...@skynet.be>
Subject Re: Loading libapreq2.dll fails on windows
Date Wed, 18 Oct 2006 19:20:50 GMT
Franky Braem wrote:
> I always get the following error:
> 
> C:\development\xampp\apache\bin>apache
> apache: Syntax error on line 143 of 
> C:/development/xampp/apache/conf/httpd.conf:
>  Cannot load bin/libapreq2.dll into server: The specified module could 
> not be found.
> 
> It seems that the dll msvcr80.dll can't be found. I've tried to put this 
> dll in the same folder, but it can't load it. How do I solve this?
> 
> Franky
> 
> 
I solved this problem as follows:

Merged the manifest files with the dll and so:

mt.exe -manifest libapreq2.dll.manifest -outputresource:libapreq2.dll;#2
mt.exe -manifest mod_apreq2.so.manifest -outputresource:mod_apreq2.so;#2

And create Microsoft.VC80.CRT.manifest with following contents:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Copyright © 1981-2001 Microsoft Corporation -->
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<noInheritable/>
<assemblyIdentity type="win32" name="Microsoft.VC80.CRT" 
version="8.0.50608.0" processorArchitecture="x86" 
publicKeyToken="1fc8b3b9a1e18e3b" />
<file name="msvcr80.dll"/>
</assembly>

And store a msvcr80.dll in the same directory as the dll and so.

Franky.


Mime
View raw message