httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Galbraith <p...@mysql.com>
Subject Re: Problems with apreq2 on OS X
Date Sun, 29 Oct 2006 19:57:19 GMT
Fred,

Ok: I have this failure on
1. OS X
2. Suse 10.0 amd 64
3. Suse 9.3   intel 32

Has anyone addressed this? This is what I would call severely broke. I 
would prefer not to use CGI. After this week, I think maybe the universe 
is telling me to learn PHP after all these years of being a perl developer.

Patrick

Fred Moyer wrote:

> Patrick Galbraith wrote:
>
>> [Sun Oct 29 12:38:27 2006] [notice] Apache/2.2.3 (Unix) mod_ssl/2.2.3 
>> OpenSSL/0.9.8d DAV/2 mod_perl/2.0.2 Perl/v5.8.8 configured -- 
>> resuming normal operations
>> dyld: lazy symbol binding failed: Symbol not found: 
>> _apreq_handle_apache2
>>  Referenced from: 
>> /opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level/auto/APR/Request/Apache2/Apache2.bundle

>>
>>  Expected in: dynamic lookup
>>
>> dyld: Symbol not found: _apreq_handle_apache2
>>  Referenced from: 
>> /opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level/auto/APR/Request/Apache2/Apache2.bundle

>>
>>  Expected in: dynamic lookup
>>
>> [Sun Oct 29 12:38:38 2006] [notice] child pid 11206 exit signal 
>> Trace/BPT trap (5)
>>
>> OS X version: Darwin radha.local 8.8.1 Darwin Kernel Version 8.8.1: 
>> Mon Sep 25 19:42:00 PDT 2006; root:xnu-792.13.8.obj~1/RELEASE_I386 
>> i386 i386
>>
>> Not sure what this is. Anyone encountered this before?
>
>
> I ran into this also, same platform.  I have been digging around a bit 
> to see if I can resolve it but no luck so far - my foo in this area 
> isn't quite where it needs to be.  This works fine for me on Linux 
> though.
>
>> Also, is there a way to have access to things like $rec->param 
>> without having to use Apache2::Request/libapreq2? I ask this in case 
>> there is no solution for getting this to work, as well as on linux 
>> distributions I cannot get libapreq2 working.
>
>
> You can use CGI.  Are you hitting this same issue on Linux?



Mime
View raw message