httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guy D" <dy2...@gmail.com>
Subject make install fails for perl modules in 2.08
Date Tue, 22 Aug 2006 15:11:23 GMT
Hello,

I recently tried to install libapr2 version 2.08 on a Solaris server
with Perl 5.8.8 and Apache 2.2.3.  This is how I configured libapreq2:

$ F77=f77 \
> CXX=CC \
> CC=cc \
>./configure \
> --enable-perl-glue \
> --with-perl=/usr/local/bin/perl \
> --with-apache2-apxs=/usr/local/apache2/bin/apxs \
> --with-apr-config=/usr/local/apache2/bin/apr-1-config \
> --with-apu-config=/usr/local/apache2/bin/apu-1-config \
> --with-expat=/usr/local/apache2

I am using Sun's Studio compilers and not gcc.

Everything compiled.  All tests passed except two (36 & 37 in util.t)

But the make install step failed to install the perl modules; instead
I got this error:

$ make install
...
cd perl; make install
Use of uninitialized value in -d at
/usr/local/perl_5.8/lib/5.8.8/File/Path.pm line 159.
fileparse(): need a valid pathname at
/usr/local/perl_5.8/lib/5.8.8/File/Path.pm line 160
*** Error code 2
The following command caused the error:
/usr/local/bin/perl -MExtUtils::Install -e 'install({@ARGV},
'\''0'\'', 0, '\''0'\'');' \
        read /auto/libapreq2/.packlist \
        write /auto/libapreq2/.packlist \
        blib/lib  \
        blib/arch  \
        blib/bin  \
        blib/script /usr/local/perl_5.8/bin \
        blib/man1  \
        blib/man3
make: Fatal error: Command failed for target `pure_vendor_install'
Current working directory /usr/local/src/cpan/build/libapreq2-2.08/glue/perl
*** Error code 1

Is this a problem with the Makefile?

Eventually, I tried to install libapreq2 version 2.07.  I used the
same configuration shown above.  There was apparently an error in a
Makefile in the module/apache2 directory (the "all-local" target was
missing; I compared this Makefile with the corresponding one in the
libapreq2 version 2.08 version and inserted an "all-local:" empty
target.)

After that, it compiled.  The make test had the same results (the same
two tests failed.)
But, this time the "cd glue/perl; make install" worked.

So, maybe there is a bug in the new version.

Regards,
Doug

Mime
View raw message