httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Geisler <sgeis...@aeccom.com>
Subject Re: libapreq 1.3 and Segmentation fault after upload
Date Thu, 22 Jun 2006 12:31:39 GMT
Hi,

I solved the issue.
I had set character set to utf8 in the HTML form with a standard upload 
and I got utf8.
I used the Apache::Upload to get the details about the upload, but 
forgot to use Encode::decode('utf8', $u->name()).

It is possible to backport character decoding to libapreq 1.x?

Sven.


Sven Geisler schrieb:
> Hi,
> 
> I'm using perl 5.8.8, apache 1.3.34, mod_perl 1.29 and libapreq 1.3.
> I'm getting sometimes Segmentation faults after an upload. I can force 
> the segmentation faults when I use larger file name. I use 
> Apache::Upload object to access the files.
> I tried with gdb to backtrace the cause, but I didn't get any idea.
> It looks to me that the segmentation fault occurs during the clean up of 
> unsed variables.
> The last function on the stack was always "free" from Perl.
> I also see sometimes "free(): invalid pointer 0xea84790!" in the logs.
> 
> 
> Does anyone have an idea?
> 
> 
> Here my compiler flags
> O3 -fno-strict-aliasing -pipe -g -mcpu=pentium4 -march=pentium4 
> -mfpmath=sse -msse2
> I using gcc (GCC) 3.2.3 20030502 (Red Hat Linux 3.2.3-47) on Red Hat 
> Enterprise Linux WS release 3 (Taroon Update 4).
> 

Mime
View raw message