httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: [RELEASE CANDIDATE] libapreq2 2.08-RC1
Date Tue, 23 May 2006 03:31:54 GMT
On Mon, 22 May 2006, Steve Hay wrote:

[ ... ]
> I have one test script failing, though.
> When I ran "nmake test" from the top-level directory every test in 
> glue\perl\t\apreq\cgi.t failed with a generic Windows popup error message 
> saying "perl.exe has encountered a problem and needs to close...":
> Failed Test   Stat Wstat Total Fail  Failed  List of 
> Failed-------------------------------------------------------------------------------t\apreq\cgi.t

> 41   41 100.00%  1-41Failed 1/10 test scripts, 90.00% okay. 41/191 subtests 
> failed, 78.53% okay.
> When I cd into glue\perl and run "nmake test" from there I get different 
> popups instead complaining about missing DLL's.  If I add their locations to 
> my PATH then I get the same "perl.exe has encountered..." messages as before.

I believe that error is the same error that arises in
many of the apr-ext tests in mod_perl (with Apache/2.2);
with httpd-2.2.2, it arises on about line 798 of apr_pools.c 
of srclib/apr/memory/unix/, in the apr_pool_create_ex()
function - the line
     if (allocator == NULL)
         allocator = parent->allocator;
has "parent" apparently NULL. If anyone has tested mod_perl
and/or libapreq under Apache/2.2 with unix, can you let
us know if you encounter problems either with mod_perl's 
apr-ext tests or withj libapreq's glue/perl/t/apreq/cgi.t
tests? Thanks.

-- 
best regards,
Randy

Mime
View raw message