httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: svn commit: r408136 - /httpd/apreq/trunk/build/version_check.pl
Date Mon, 22 May 2006 04:52:45 GMT
On Sun, 21 May 2006, Philip M. Gollucci wrote:

>> I'd prefer that no version of Archive::Tar be specified
>> for Win32, or perhaps even no such prerequisite at all;
>> it's a core module in ActivePerl, and has a history
>> of some instability on Win32 - an upgrade may break
>> things on the local system.
>> 
> I was trying to address this from Steven Hay's post:
>>> - When I ran "perl Makefile.PL --with-apache2=C:/apache2" I got an >>error

> from win32/Configure.pl about Archive-Tar being missing, but >>this is not 
> mentioned in the PREREQUISITES file and was not checked by >>test_prereq in 
> Makefile.PL before calling this script.

It's a trade-off - Steve builds his own perl, so having
Archive::Tar as a prerequisite makes sense, but especially
requiring a particular version may mess up an ActivePerl
with an older version. So I think requiring version "0"
may be safest.

> I'm fine with whatever you say is best... I'm not a MS guy.
>
> I guess people on cygwin using the cygwin perl shouldn't be using the 
> win32/Configure.pl. (I don't think Steven is)

That's right, on both counts.

-- 
best regards,
Randy


Mime
View raw message