httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Thames <st...@softlife.com>
Subject Re: libapreq2 installation
Date Sun, 05 Mar 2006 13:46:23 GMT
I solved this, finally, by downloading the SRPMS for libapreq2 2.07
and mod_perl 2.0.1, rebuilding and reinstalling.  All tests worked
fine.  Don't know what the problem was.  Moving on.

Thanks for your input.

On Fri, 03 Mar 2006 14:58:12 -0800, Steve Thames <steve@softlife.com>
wrote:

>I have been trying to install libapreq2 on Fedore FC4 with no luck.
>Nearly all the tests work but all tests in glue/perl/t/apreq/cgi.t
>fail.
>
>I am installing as root but have 777 permissions on the entire /root
>directory.  When that did not work, I change the user:group to
>nobody:nobody for everything in the /root directory--no luck.
>
>I ran strace against all the tests in cgi.t and found no access or
>permission errors.  Here is the error from the error log:
>
>>Can't load '/root/build/libapreq2-2.07/glue/perl/t/cgi-bin/../../blib/arch/auto/APR/Request/Request.so'
for module APR::Request: libapreq2.so.2: cannot open shared object file: No such file or directory
at /usr/lib/perl5/5.8.6/i386-linux-thread-multi/DynaLoader.pm line 230.
>>[Fri Mar 03 13:49:49 2006] [error] [client 127.0.0.1]  at /root/build/libapreq2-2.07/glue/perl/t/cgi-bin/../../blib/lib/APR/Request/Param.pm
line 27
>>[Fri Mar 03 13:49:49 2006] [error] [client 127.0.0.1] Compilation failed in require
at /root/build/libapreq2-2.07/glue/perl/t/cgi-bin/../../blib/lib/APR/Request/Param.pm line
27.
>>[Fri Mar 03 13:49:49 2006] [error] [client 127.0.0.1] BEGIN failed--compilation aborted
at /root/build/libapreq2-2.07/glue/perl/t/cgi-bin/../../blib/lib/APR/Request/Param.pm line
27.
>>[Fri Mar 03 13:49:49 2006] [error] [client 127.0.0.1] Compilation failed in require
at /root/build/libapreq2-2.07/glue/perl/t/cgi-bin/test_cgi.pl line 11.
>>[Fri Mar 03 13:49:49 2006] [error] [client 127.0.0.1] BEGIN failed--compilation aborted
at /root/build/libapreq2-2.07/glue/perl/t/cgi-bin/test_cgi.pl line 11.
>>[Fri Mar 03 13:49:49 2006] [error] [client 127.0.0.1] Premature end of script headers:
test_cgi.pl
>
>The Request.so file does exist so I can only assume there is some file
>Request.so can not find and the error is being reported this way from
>Dynaloader.pm.
>
>Obvously the results from the cgi.t tests are 500 errors resulting
>from the above errors.
>
>Hardware: Dell PowerEdge 1850 - Dual 2.8 Ghz procs
>OS:            Fedora Core 4 Linux 2.6.11-1.1369_FC4smp
>Apache:    2.0.54
>Perl:          5.8.6
>Mod Perl:  2.00002
>
>I have verified all listed prerequisites for libapreq2.
>
>I would really like to use this tool so if anyone has any ideas, I
>would be thankful.
>


Mime
View raw message