httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Ambrosino" <jbambros...@gmail.com>
Subject problems making libapreq: "modperl_perl_unembed.h: No such file or directory"
Date Thu, 09 Mar 2006 16:53:15 GMT
Hi folks,

I'm trying to build libapreq2-2.04_03-dev, and I can't get past this
problem.  During make, it fails to find "modperl_perl_unembed.h".  Any
suggestions?

Here's the make output:

/usr/local/bin/perl /usr/local/lib/perl5/5.8.8/ExtUtils/xsubpp 
-typemap /usr/local/lib/perl5/5.8.8/ExtUtils/typemap -typemap
/usr/local/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi/auto/Apache/typemap
-typemap ../../typemap  Cookie.xs > Cookie.xsc && mv Cookie.xsc
Cookie.c
gcc -c  -I/usr/src/libapreq2-2.04-dev/glue/perl/xs
-I/usr/src/libapreq2-2.04-dev/src
-I/usr/src/libapreq2-2.04-dev/glue/perl/xsbuilder -I/var/httpd/include
 -I/var/httpd/include   -I/var/httpd/include  -D_REENTRANT
-D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe
-Wdeclaration-after-statement -I/usr/local/include
-I/usr/local/lib/perl5/5.8.8/i686-linux-thread-multi/CORE -DMOD_PERL
-DMP_IOBUFSIZE=16384 -O2   -DVERSION=\"2.04-dev\"
-DXS_VERSION=\"2.04-dev\" -fpic
"-I/usr/local/lib/perl5/5.8.8/i686-linux-thread-multi/CORE"   Cookie.c
In file included from Cookie.xs:32:
/usr/src/libapreq2-2.04-dev/glue/perl/xsbuilder/apreq_xs_postperl.h:21:34:
modperl_perl_unembed.h: No such file or directory
In file included from
/usr/src/libapreq2-2.04-dev/glue/perl/xsbuilder/apreq_xs_postperl.h:24,
                 from Cookie.xs:32:
/usr/src/libapreq2-2.04-dev/glue/perl/xsbuilder/ppport.h:231:1:
warning: "PERL_UNUSED_DECL" redefined
In file included from Cookie.xs:28:
/usr/local/lib/perl5/5.8.8/i686-linux-thread-multi/CORE/perl.h:163:1:
warning: this is the location of the previous definition
make[5]: *** [Cookie.o] Error 1
make[5]: Leaving directory
`/usr/src/libapreq2-2.04-dev/glue/perl/xs/Apache/Cookie'
make[4]: *** [subdirs] Error 2
make[4]: Leaving directory `/usr/src/libapreq2-2.04-dev/glue/perl/xs/Apache'
make[3]: *** [subdirs] Error 2
make[3]: Leaving directory `/usr/src/libapreq2-2.04-dev/glue/perl/xs'
make[2]: *** [subdirs] Error 2
make[2]: Leaving directory `/usr/src/libapreq2-2.04-dev/glue/perl'
make[1]: *** [perl_glue] Error 2
make[1]: Leaving directory `/usr/src/libapreq2-2.04-dev/glue'
make: *** [all-recursive] Error 1

FYI, I'm building against http 2.0.54 and mod_perl-2.0.0-RC4.  There's
a long explanation as to why I can't use the latest MP and libapreq
sources, but suffice to say I need to use these versions for the time
being.

Also, I'm using Perl modules ExtUtils-MakeMaker-6.21 and
ExtUtils-XSBuilder-0.25.

thanks,
Jeff

Mime
View raw message