httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Stokhof" <erik.stok...@isogen-lifescience.com>
Subject build problems
Date Tue, 28 Mar 2006 15:12:35 GMT
Hi all,
I try to build libapreq2 on a Fedora Core machine, apache 2.0.53, mod_perl
2.03, libapreq2-2.06, but the tests fail each time in the api/CGI section.
In the log, I find 

[Tue Mar 28 16:54:40 2006] [error] [client 127.0.0.1] failed to resolve
handler `TestAPI::param': Can't find 'boot_APR__Brigade' symbol in
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/APR/Brigade/Brig
ade.so\n at
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/APR/XSLoader.pm line
30\nCompilation failed in require at
/home/webuser/libapreq2-2.06-dev/glue/perl/blib/lib/APR/Request/Param.pm
line 29.\nBEGIN failed--compilation aborted at
/home/webuser/libapreq2-2.06-dev/glue/perl/blib/lib/APR/Request/Param.pm
line 29.\nCompilation failed in require at
/home/webuser/libapreq2-2.06-dev/glue/perl/t/response/TestAPI/param.pm line
10.\nBEGIN failed--compilation aborted at
/home/webuser/libapreq2-2.06-dev/glue/perl/t/response/TestAPI/param.pm line
10.\nCompilation failed in require at (eval 23) line 3.\n

which makes sense, because nm
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/APR/Brigade/Brig
ade.so
does indeed not show the boot_APR__Brigade symbol.
Still, I get the feeling something else is wrong, but I can't figure out
what. Can anybody help me?

-Erik


Mime
View raw message