httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@taperfriendlymusic.org>
Subject Re: 2.07-rc4 available for testing
Date Tue, 07 Feb 2006 05:19:01 GMT
Randy Kobes wrote:
> On Thu, 2 Feb 2006, Joe Schaefer wrote:
> 
>> Please download, test, and report back on the following
>> candidate tarball:
>>
>>  http://people.apache.org/~joes/libapreq2-2.07-rc4.tar.gz
> Sorry for the delay ... This builds and tests successfully,
> including the perl glue, on both:
> 
> - Win32 (ActivePerl 815), with Apache/2.0.55 (winnt)
> 
> - linux (perl-5.8.7), with Apache/2.0.54 (prefork).

I got a test failure on my Linux based environment.  I'm using Apache 
2.2.0 with a trimmed down compilation.  I'm not sure if 2.2 is 
officially supported yet but I thought that I would submit this report 
in case it is.  The following test failure was repeatable and generated 
the same results under -verbose.

----------------

waiting 60 seconds for server to start: ok (waited 0 secs)
server localhost:8529 started
t/apreq/upload....1..20
# Running under perl version 5.008006 for linux
# Current time local: Mon Feb  6 21:17:13 2006
# Current time GMT:   Tue Feb  7 05:17:13 2006
# Using Test.pm version 1.25
# Using Apache/Test.pm version 1.28
request has failed (the response code was: 404)
see t/logs/error_log for more details
dubious
	Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED tests 1-20
	Failed 20/20 tests, 0.00% okay
Failed Test      Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/apreq/upload.t  255 65280    20   40 200.00%  1-20
Failed 1/1 test scripts, 0.00% okay. 20/20 subtests failed, 0.00% okay.

---------------

perl Makefile.PL  --with-apache2-apxs /home/fred/dev/httpd2/bin/apxs

----------

perl: 5.8.6 ok
mod_perl: 2.000003 ok
Apache::Test: 1.28 ok
ExtUtils::MakeMaker: 6.17 ok
ExtUtils::XSBuilder: 0.27 ok
Test::More: 0.62 ok

---------

httpd -l

Compiled in modules:

   core.c
   mod_cache.c
   mod_mem_cache.c
   mod_deflate.c
   mod_log_config.c
   mod_headers.c
   mod_setenvif.c
   mod_proxy.c
   mod_proxy_http.c
   prefork.c
   http_core.c
   mod_mime.c
   mod_negotiation.c
   mod_so.c

----------------

ls glue/perl/t/htdocs/
index.html

------------------

[Mon Feb 06 20:57:08 2006] [debug] filter.c(269): [client 127.0.0.1] 
prefetching 65536 bytes
b saw EOS at 
/home/fred/dev/src/libapreq2-2.07/glue/perl/t/response/TestApReq/request.pm 
line 21.
[Mon Feb 06 20:57:08 2006] [debug] filter.c(269): [client 127.0.0.1] 
prefetching 65536 bytes
Running MAGIC ITERATOR tests at 
/home/fred/dev/src/libapreq2-2.07/glue/perl/t/response/TestApReq/request.pm 
line 146.
[Mon Feb 06 20:57:08 2006] [error] [client 127.0.0.1] File does not 
exist: 
/home/fred/dev/src/libapreq2-2.07/glue/perl/t/htdocs/getfiles-binary-httpd
[Mon Feb 06 20:57:08 2006] [info] removed PID file 
/home/fred/dev/src/libapreq2-2.07/glue/perl/t/logs/httpd.pid (pid=11565)
[Mon Feb 06 20:57:08 2006] [notice] caught SIGTERM, shutting down


Mime
View raw message