httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Boysenberry Payne <boysenbe...@humaniteque.com>
Subject Re: make error
Date Fri, 24 Feb 2006 00:08:36 GMT
> cd LIBAPREQ2.0.7
> 	./configure --with-expat=/usr/local/apr  
> --with-apache2-apxs=/usr/local/apache2/bin/apxs --enable-perl-glue
> 	make
> 	make test
> 	make install

I downloaded Expat-2.0, which got rid of the first error.
Then after I added "--enable-perl-glue" I realized I needed to install 
MP2 first.
Once that was installed I received the following error:

Can't locate ExtUtils/XSBuilder/ParseSource.pm in @INC (@INC contains: 
/System/Library/Perl/5.8.1/darwin-thread-multi-2level 
/System/Library/Perl/5.8.1 
/Library/Perl/5.8.1/darwin-thread-multi-2level /Library/Perl/5.8.1 
/Library/Perl /Network/Library/Perl/5.8.1/darwin-thread-multi-2level 
/Network/Library/Perl/5.8.1 /Network/Library/Perl .) at Makefile.PL 
line 22.
BEGIN failed--compilation aborted at Makefile.PL line 22.

Then I ran cpan and downloaded ExtUtils::XSBuilder

make now runs fine.

When I do make test I get the following error:
waiting 60 seconds for server to start: .Syntax error on line 168 of 
/Users/boysie/src/libapreq2-2.07/module/t/conf/httpd.conf:
Cannot load 
/Users/boysie/src/libapreq2-2.07/module/apache2/.libs/mod_apreq2.so 
into server: dyld: /usr/local/apache2/bin/httpd can't open library: 
/usr/local/apache2/lib/libapreq2.2.dylib  (No such file or directory, 
errno = 2)\n

Any ideas?

Thanks,
Boysenberry

boysenberrys.com | habitatlife.com | selfgnosis.com

On Feb 23, 2006, at 4:52 PM, Jonathan Vanasco wrote:

>
> cd LIBAPREQ2.0.7
> 	./configure --with-expat=/usr/local/apr  
> --with-apache2-apxs=/usr/local/apache2/bin/apxs --enable-perl-glue
> 	make
> 	make test
> 	make install
>
> note: if you're running any of  the perl xml stuff on osx, you'll also 
> need to download and install expat from sourceforge separately.  
> getting perl modules to install on osx using the apache expat is damn 
> frustrating.  having 2 sep. libs is ugly, but it works.
>
> On Feb 23, 2006, at 5:44 PM, Boysenberry Payne wrote:
>
>> I'm getting:
>> ld: can't locate file for: -lexpat
>>
>> While trying to build on OS X 10.3.9 / Apache 2.0.55
>>
>> When I 'find /usr -name "*expat*" I get:
>>
>> /usr/include/php/ext/xml/expat
>> /usr/include/php/ext/xml/expat/expat.h
>> /usr/local/apache2/include/expat.h
>> /usr/local/apache2/lib/libexpat.0.1.0.dylib
>> /usr/local/apache2/lib/libexpat.0.dylib
>> /usr/local/apache2/lib/libexpat.a
>> /usr/local/apache2/lib/libexpat.dylib
>> /usr/local/apache2/lib/libexpat.la
>> /usr/local/share/doc/libxml2-2.6.23/html/tutorial/includexpath.c
>> /usr/share/doc/libxml2-2.6.16/html/tutorial/includexpath.c
>> /usr/X11R6/include/expat.h
>> /usr/X11R6/lib/libexpat.1.0.dylib
>> /usr/X11R6/lib/libexpat.1.dylib
>> /usr/X11R6/lib/libexpat.a
>> /usr/X11R6/lib/libexpat.dylib
>>
>> Am I missing expat, or is something conflicted?
>>
>> Thanks,
>> Boysenberry
>>
>> boysenberrys.com | habitatlife.com | selfgnosis.com
>>
>
>
>


Mime
View raw message