httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rian Hunter <r...@MIT.EDU>
Subject autotools woe
Date Thu, 29 Dec 2005 02:44:55 GMT
Hi,

I'm not currently on this list so it would be really great if you could
cc me with your replies.

I just checked out the latest apreq from svn but I'm having problems
with ./buildconf and autotools. I have all the latest GNU autotools
(autoconf 2.59, automake 1.9.1, libtool 1.5.8) but when ./buildconf gets
to aclocal it gives me "aclocal:configure.ac:22: warning: macro
`AM_PROG_LIBTOOL' not found in library" I'm not an autotools guru but I
think the AM_PROG_LIBTOOL macro in configure.ac is deprecated in favor
of AC_PROG_LIBTOOL. aclocal doesn't fail after this message, but
autoconf does fail with:

configure.ac:22: error: possibly undefined macro: AM_PROG_LIBTOOL
      If this token and others are legitimate, please use
m4_pattern_allow.
      See the Autoconf documentation.

I think this has to do with the order in which th autotools are run (for
instance I think libtoolize is supposed to be run after aclocal, but
then again I am not certain). What versions of the tools do you guys
run? Any ideas about how to fix this? I'm running FreeBSD 5.3 and all my
tools are from the ports collection. Thanks!

Rian Hunter



Mime
View raw message