httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bengt-Arne Fjellner" <Bengt-Arne.Fjell...@ltu.se>
Subject Resolved: cant build libapreq2 on trustix linux
Date Wed, 02 Nov 2005 09:43:19 GMT
>
>system trustix secure linux version 2.2
>
>perl 5.8.5  all cpan modules up to date
>mod_perl 2.0.1
>
>tried with normal and cvs version of libapreq2-2.06-dev
>both on a prodution system and on a clean system.
>Almost all tests in parsers fail with: Segmentation fault
>see attached files:
>compile.txt:
>  ./buildconf
>  perl Makefile.PL --with-apache2-apxs=/usr/sbin/apxs
>  make
>  make test
>  cd library/t && ./parsers
Finally resolved:
export CFLAGS=`apxs -q CFLAGS`
before Perl Makefile.PL  fixed it.

shouldnt configure take this into account ????
hope this helps someone else.
p.s. result of apxs -C CFLAGS
-O3 -fomit-frame-pointer -pipe -s -mpentium -mcpu=pentium -march=pentium
-fexpensive-optimizations -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES=1
-D_LARGEFILE64_SOURCE=1


-- 
Bengt-Arne Fjellner
Luleå technical university
LTU Skellefteå
Skellefteå
Sweden



-- 
Bengt-Arne Fjellner
0910-58 53 69



Mime
View raw message