httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: towards a 2.07 release
Date Thu, 06 Oct 2005 18:04:00 GMT
Stas Bekman <stas@stason.org> writes:

> Shouldn't this be fatal? (now it continues to run and you can be sure that 
> noone will notice that suggestion)
>
> it fails only later when you run make.

>From `svn log Makefile.PL`:

    r165547 | randyk | 2005-05-01 17:54:26 -0400 (Sun, 01 May 2005) | 4 lines

    When testing perl prerequisites, warn, rather than die, on
    failure, so as CPAN clients have a chance to install missing
    prerequisites.

Is there a way (some environment variable perhaps) to tell whether
we're running under a CPAN client or not?  That way we could die()
in the non-cpan case.

> Unfortunately there is still no way to pass -libmodperl option anywhere in 
> Makefile.PL stage, so after getting a few dozen core files, I have to go 
> manually and run:

I think Philip was working on this-  IIRC he added an MM_OPTS to
./configure but hasn't gotten round to updating Makefile.PL.


-- 
Joe Schaefer


Mime
View raw message