httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: towards a 2.07 release
Date Wed, 05 Oct 2005 00:59:14 GMT
Randy Kobes wrote:
> On Sun, 2 Oct 2005, Joe Schaefer wrote:
> 
>> Note this is our first non-dev candidate, so please give it the
>> extra scrutiny it deserves. Release Candidate #1 -
>>
>>    http://people.apache.org/~joes/libapreq2-2.07-rc1.tar.gz
>>
>> Thanks!
> 
> 
> Nice work, Joe! All tests, including those of the perl
> glue, pass for me on
>    linux: Apache/2.0.54 prefork, perl-5.8.7, mp 2.0.1
>    Win32: Apache/2.0.54 winnt, perl-5.8.7, mp 2.0.1 

perl Makefile.PL --with-apache2-apxs=/home/stas/httpd/prefork/bin/apxs
perl: 5.8.7 ok
mod_perl: 2.000001 ok
Apache::Test: 1.25 ok
ExtUtils::MakeMaker: 6.17 ok
build/version_check.pl failed: no version_string found in '' for 
'ExtUtils::XSBuilder'.
Please upgrade ExtUtils::XSBuilder first.

Shouldn't this be fatal? (now it continues to run and you can be sure that 
noone will notice that suggestion)

it fails only later when you run make.

===================================

If I get the wrong mod_perl.so loaded I get libapreq segfaulting in 
modperl tests:

#0  0xb796b79f in boot_APR__Request (my_perl=0x81b9c80, cv=0x821c3f0)
     at Request.c:616
616         XS_VERSION_BOOTCHECK ;

Thread 1 (process 1958):
#0  0xb796b79f in boot_APR__Request (my_perl=0x81b9c80, cv=0x821c3f0)
     at Request.c:616
#1  0xb7a8e3b0 in Perl_pp_entersub (my_perl=0x81b9c80) at pp_hot.c:2788
#2  0xb7a644da in Perl_runops_debug (my_perl=0x81b9c80) at dump.c:1597
#3  0xb79f6613 in S_call_body (my_perl=0x81b9c80, myop=0xbf86e4b8, 
is_eval=0 '\0')
     at perl.c:2617
#4  0xb79f60dc in Perl_call_sv (my_perl=0x81b9c80, sv=0x8201bf0, flags=6)
     at perl.c:2546
#5  0xb79fbb3b in S_call_list_body (my_perl=0x81b9c80, cv=0x8201bf0) at 
perl.c:5123
#6  0xb79fb578 in Perl_call_list (my_perl=0x81b9c80, oldscope=18,
     paramList=0x8201d28) at perl.c:5062

Unfortunately there is still no way to pass -libmodperl option anywhere in 
Makefile.PL stage, so after getting a few dozen core files, I have to go 
manually and run:

cd /glue/perl
t/TEST -libmodperl /home/stas/httpd/prefork/modules/mod_perl-5.8.7-ithread.so

now everything works fine.

====================================

tested with linux, perl-5.8.7-ithreads, apache/2.0.55-dev

-- 
_______________________________________________________________
Stas Bekman mailto:stas@stason.org   | http://stason.org/
MailChannels: Assured Messaging (TM) | http://mailchannels.com/
The "Practical mod_perl" book        | http://modperlbook.org/


Mime
View raw message