httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Boysenberry Payne <boysenbe...@humaniteque.com>
Subject make test errors on OS X 10.3.9
Date Mon, 19 Sep 2005 23:10:41 GMT
I'm trying to get libapreq2-2.06-dev installed on OS X 10.3.9

When I run make test I get the following errors:

/opt/local/bin/perl -MTest::Harness -e 'runtests(@ARGV)' version.t 
cookie.t params.t parsers.t error.t util.t
version....dyld: 
/Users/boysie/src/libapreq2-2.06-dev/library/t/.libs/version version 
mismatch for library: /usr/local/lib/libiconv.2.dylib (compatibility 
version of user: 6.0.0 greater than library's version: 5.0.0)
version....dubious
         Test returned status 0 (wstat 5, 0x5)
cookie.....dyld: 
/Users/boysie/src/libapreq2-2.06-dev/library/t/.libs/cookie version 
mismatch for library: /usr/local/lib/libiconv.2.dylib (compatibility 
version of user: 6.0.0 greater than library's version: 5.0.0)
cookie.....dubious
         Test returned status 0 (wstat 5, 0x5)
params.....dyld: 
/Users/boysie/src/libapreq2-2.06-dev/library/t/.libs/params version 
mismatch for library: /usr/local/lib/libiconv.2.dylib (compatibility 
version of user: 6.0.0 greater than library's version: 5.0.0)
params.....dubious
         Test returned status 0 (wstat 5, 0x5)
parsers....dyld: 
/Users/boysie/src/libapreq2-2.06-dev/library/t/.libs/parsers version 
mismatch for library: /usr/local/lib/libiconv.2.dylib (compatibility 
version of user: 6.0.0 greater than library's version: 5.0.0)
parsers....dubious
         Test returned status 0 (wstat 5, 0x5)
error......dyld: 
/Users/boysie/src/libapreq2-2.06-dev/library/t/.libs/error version 
mismatch for library: /usr/local/lib/libiconv.2.dylib (compatibility 
version of user: 6.0.0 greater than library's version: 5.0.0)
error......dubious
         Test returned status 0 (wstat 5, 0x5)
util.......dyld: 
/Users/boysie/src/libapreq2-2.06-dev/library/t/.libs/util version 
mismatch for library: /usr/local/lib/libiconv.2.dylib (compatibility 
version of user: 6.0.0 greater than library's version: 5.0.0)
util.......dubious
         Test returned status 0 (wstat 5, 0x5)
FAILED--6 test scripts could be run, alas--no output ever seen
make[2]: *** [test] Error 255
make[1]: *** [test] Error 2
make: *** [library_test] Error 2

I tried installing the latest iconv "libiconv-1.9.1" but it gives me 
the same kind of error with
2.0.0 compatibility errors instead.

Is there a way to get it to build using the correct libraries?

Any help is much appreciated

Thanks,
Boysenberry

boysenberrys.com | habitatlife.com | selfgnosis.com

Mime
View raw message