httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: Dual expat link failure
Date Fri, 22 Jul 2005 23:05:58 GMT
Joe Schaefer <joe+gmane@sunstarsys.com> writes:

> Jared Rhine <jared@wordzoo.com> writes:
>
>> gcc -g -O2 -o .libs/test_cgi test_cgi.o
>> /var/tmp/apache-inst-01-build/libapreq2-2.06-dev/library/.libs/libapreq2.so
>> /usr/local/apache-inst-01/lib/libexpat.so -lgdbm -ldb -lexpat -liconv
>> /usr/local/apache-inst-01/lib/libapr-0.so -lsendfile -lrt -lm -lsocket
>> -lnsl -lresolv -lpthread /usr/local/apache-inst-01/lib/libaprutil-0.so
>> -R/usr/local/apache-inst-01/lib
>>
>> ld: fatal: recording name conflict: file
>> `/usr/local/apache-inst-01/lib/libexpat.so' and file
>> `/opt/csw/lib/libexpat.so' provide identical dependency names:
>> libexpat.so.0 (possible multiple inclusion of the same file) ld:
>> fatal: File processing errors. No output written to .libs/test_cgi
>
>
> Looks like a bug in some config script.  What's the output of
>
>     /usr/local/apache-inst-01/bin/apu-config --link-libtool --libs
> ?

Also take a look at this patch (from the module/ dir), 
which removes some weird linker flags LDFLAGS.  
If you also apply this change to your for Makefile.in, 
see if the extra -lexpat flag goes away.

Index: Makefile.am
===================================================================
--- Makefile.am	(revision 219832)
+++ Makefile.am	(working copy)
@@ -4,7 +4,7 @@
 EXTRA_DIST = t apache
 
 noinst_PROGRAMS = test_cgi
-test_cgi_LDFLAGS =  `@APREQ_CONFIG@ --link-libtool --libs` @APR_LTFLAGS@
+test_cgi_LDFLAGS =  `@APREQ_CONFIG@ --link-libtool`
 
 run_tests : t/TEST
 	-cp -f test_cgi t/cgi-bin

-- 
Joe Schaefer


Mime
View raw message