httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <pgollu...@p6m7g8.com>
Subject Re: [PATCH[ library/t/Makefile.am
Date Sun, 10 Jul 2005 23:26:40 GMT
Philip M. Gollucci wrote:
> I've reached a conundrum here:
> With the above fix, ./buildconf actually finishes because automake 
> doesn't error out with the above error, but
> gmake test
> fails in library/t
> because the linker flags aren't passed in library/t/Makefile.am
I finally figured this out:
This is due to an inconsistency in automake15's version string
running

automake15 --version
automake (GNU automake15) 1.5

VS

automak19
automake (GNU automake) 1.9.5

Note the extra 15.  15 is > 1.6 so the buildconf let me use an 
unsupported version of automake.

Here is a patch to solve this:
[also note the s/Apache::Request/Apache2::Request/]


pgollucci@smgellar /usr/local/dev/repos/ASF/httpd/apreq/trunk> svn diff 
build/version_check.pl
Index: build/version_check.pl
===================================================================
--- build/version_check.pl      (revision 210049)
+++ build/version_check.pl      (working copy)
@@ -7,8 +7,25 @@
  $path = $tool unless defined $path;

  sub exe_version { scalar qx/$path -v/ }
-sub gnu_version { scalar qx/$path --version/ }
+sub gnu_version {
+     my $ver = scalar qx/$path --version/;

+     if ($path =~ /automake/) {
+          if ($ver =~ /15/) {
+              ## automake15 --version displays
+              ## automake (GNU automake15) 1.5
+              ## causing us to use 15 as the version and not 1.5
+              return 1.5;
+          }
+          else {
+              return $ver;
+          }
+                }
+     else {
+         return $ver;
+     }
+}
+
  sub xsb_version {
      eval {
          require ExtUtils::XSBuilder;
@@ -197,7 +214,7 @@
              "Build system (core C API) prerequisites\n", \%build;
          print "\n", "=" x 50, "\n";
          print_prereqs
-            "Perl glue (Apache::Request) prerequisites\n", \%perl_glue;
+            "Perl glue (Apache2::Request) prerequisites\n", \%perl_glue;
          print "\n", "=" x 50, "\n";
          print_prereqs
              "Additional prerequisites for apreq subversion builds\n", 
\%svn;

-- 
END
------------------------------------------------------------
     What doesn't kill us can only make us stronger.
                 Nothing is impossible.
				
Philip M. Gollucci (pgollucci@p6m7g8.com) 301.254.5198
Consultant / http://p6m7g8.net/Resume/resume.shtml
Senior Developer / Liquidity Services, Inc.
   http://www.liquidityservicesinc.com
        http://www.liquidation.com
        http://www.uksurplus.com
        http://www.govliquidation.com
        http://www.gowholesale.com


Mime
View raw message