httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jonathan vanasco <jvana...@mastersofbranding.com>
Subject Re: Problem with -path in Apache2::Cookie?
Date Sat, 28 May 2005 05:00:20 GMT

Just to add onto the issue below:
	my $cookie = Apache2::Cookie->new($r, -path => $mypath...)

I experienced something similar -- domain and path both were set to 
what i specified for path

I tried a workaround for domain, and ended up having the path set to 
the expiration argument ('+365'), while expiration was set to the 
expiration date ('Sun, 28-May-2006 04:54:37 GMT')

specifiying the domain and path, re: the workaround, fixes it all up

Mac OSX 10.3.9
libapreq whatever is current.tgz on May 28
apache 2.0.5.4
modperl whatever is current.bz2 on May 28
perl 5.8.1 (stock osx)



	

On May 13, 2005, at 1:05 AM, Joe Schaefer wrote:

> Fred Moyer <fred@taperfriendlymusic.org> writes:
>
>> [cc'ing the apreq-dev@httpd.apache.org list]
>>
>> Pete Houston wrote:
>>> Yes, I found exactly the same behaviour yesterday, and it did affect
>>> Firefox too. I used the same workaround which seems to work in all 
>>> the
>>> scenarios I tested.
>>
>> So it sounds like this is an issue with dev_2.05.  I'll dig into it 
>> if I
>> get a chance, but this is probably a no-brainer for someone 
>> experienced
>> with the codebase.
>
> Problem ack'd; I've no clue why this happens tho.  Must be some
> XS-related bug.  I'll add a new test to trunk which tickles it,
> so others can whittle away as well.
>
> -- 
> Joe Schaefer
>


Mime
View raw message