httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <pgollu...@p6m7g8.com>
Subject Re: expat install libapreq2-2.0.5-dev
Date Mon, 23 May 2005 20:16:37 GMT
Marc Lambrichs wrote:

> Marc Lambrichs wrote:
>
>> I'm trying to install libapreq2-2.0.5-dev on freebsd 5.4 box. Error 
>> "/usr/bin/ld: cannot find -lexpat" pops up. I've checked 
>> /usr/local/lib/libexpat.a exists and in the Makefile
>> libdir is ok ( /usr/local/lib ) and
>> APR_LDFLAGS contains -L/usr/local/lib
>> What's wrong?
>>
>> Cheers,
>> Marc
>>
>>
> Creating links in /usr/local/lib/apache2 solved that problem.
>
> But wait, there's more.
> In file included from Apache2.xs:39
> /home/mlambrichs/libapreq2-2.05-dev/glue/perl/xsbuilder/apreq_xs_postperl.h:21:34: 
> modperl_unembed.h: No such file or directory
>
> Somehow I'm under the impression that the Makefile isn't fit for my 
> system.
>
> Marc

Use gmake not make.

Also, there is an option to ./configure --with-expat=[DIR]
you should use it. I added it for FBSD :)  I've only tested in 6-x 
current though.

./configure --with-expat=/usr/local


Also make sure you're using
/usr/ports/textproc/expat2


-- 
END 
---------------------------------------------------------
    What doesn't kill us, can only make us stronger.
               Nothing is impossible.
				
Philip M. Gollucci (pgollucci@p6m7g8.com) 301.254.5198
Consultant / http://p6m7g8.net/Resume/resume.shtml
Senior Developer / Liquidity Services, Inc.  
     http://www.liquidityservicesinc.com


Mime
View raw message