httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From terry spencer <terryintran...@yahoo.com>
Subject terryintransit@yahoo.com
Date Tue, 08 Mar 2005 20:42:05 GMT
Thaks for you comments. Interesting, Ill try that
with a lower version of perl.

BTW: I managed to compile libapreq-1.33 on AIX. 

In the following files 
./Cookie/MakeFile
./Request/MakeFile

Alter

OTHERLDFLAGS =
-bI:/omnitest/external/perl-5.8.3/lib/site_perl/5.8.3/aix/auto/Apache/mod_perl.exp

To

OTHERLDFLAGS =
-bI:/omnitest/external/perl-5.8.3/lib/site_perl/5.8.3/aix/auto/Apache/mod_perl.exp
-bI:/opt/omni/software/external/apache-1.3.29/libexec/httpd.exp


Using your correct path to httpd.exp :):

Another mailing suggested 

OTHERLDFLAGS =
-Wl,-bI:/omnitest/external/perl-5.8.3/lib/site_perl/5.8.3/aix/auto/Apache/mod_perl.exp
-Wl,-bI:/opt/omni/software/external/apache-1.3.29/libexec/httpd.exp


However it failed with the Wl flag for me.

This change allowed me to compile, but the make test
failed.

>> Hi All,
>> 
>> Im trying to install libapreq-1.33 on AIX, and an
>> error occurs when I try to make. Other installed
>> packages are (not an exclusive list):
>> * mod_perl-1.27
>> * Apache_1.3.27
>> * perl-5.8.3
>> Im intending to install Mason, so have the other
>> prerequisites that come with that. 
>Hi,
>
>As far as I can tell,
>all my attempts to build libapreq-1 on aix 4.3 
>with perl 5.8 and IBM's VAC C Compiler version 5, or
GNU gcc 
>have failed :-)
>
>The only combination that worked for me was
>perl 5.6.1
>IBM VAC compiler
>apache 1.3.29 built _WITH_ mod_so
>mod_perl 1.29
>
>I used something like
>    cd $mod_perl_dir                    &&
>    perl Makefile.PL                    \
>    APACHE_PREFIX=$APA_PREFIX           \
>    APACHE_SRC=$apache_dir/src          \
>    DO_HTTPD=1                          \
>    USE_APACI=1                         \
>    APACI_ARGS='--enable-module=so'     \
>    EVERYTHING=1                        &&
>    make                                &&
>    make test                           &&
>    make install                        &&
>    cd $apache_dir                      &&
>    make install
>
>note that without APACI_ARGS="--enable-module=so'
>it won't work on AIX.
>
>I tried the same trick with perl 5.8,
>but without success
>
>Hope this helps
>
>José



	
		
__________________________________ 
Celebrate Yahoo!'s 10th Birthday! 
Yahoo! Netrospective: 100 Moments of the Web 
http://birthday.yahoo.com/netrospective/

Mime
View raw message