httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Sabol" <sa...@alderaan.gsfc.nasa.gov>
Subject Re: "make test" fails: missing mod_apreq.so and problems in t/apreq/cgi
Date Tue, 08 Feb 2005 04:40:10 GMT
>> IIRC the prereqs we list for the auto|libtool stuff
>> are the minimum versions I've tested debian against 
>> at some point.  If you can find newer versions for
>> RedHat 7.3 that actually work for you, let us know 
>> and we should be able to bump the prereqs accordingly.
>
> Yeah, I'll try upgrading libtool and report back.
>
> FYI, the version of libtool (1.4.2) that I'm using is from /usr/bin, so this
> presumably should affect all Red Hat 7.3 users....

In an attempt to find the minimum required version, I upgraded libtool from
1.4.2 to 1.4.3 (instead of the latest version) and "make test" works fine
with libtool 1.4.3. Technically, you can "make install" with libtool 1.4.2,
but you can't "make test". I'm not sure if that's grounds for officially
making libtool 1.4.3 the minimum required version for buildconf or not? I
would say yes. Here's a trivial patch:

Index: build/version_check.pl
===================================================================
--- build/version_check.pl      (revision 151824)
+++ build/version_check.pl      (working copy)
@@ -42,7 +42,7 @@
 }
 
 my %svn = (
-                libtool => { version => "1.4.2",   test => \&gnu_version },
+                libtool => { version => "1.4.3",   test => \&gnu_version },
                autoconf => { version => "2.53",    test => \&gnu_version },
                automake => { version => "1.4.0",   test => \&gnu_version },
                 doxygen => { version => "1.2",     test => \&gnu_version },

Mime
View raw message