httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: t/apreq/cgi.t failing to find libapr.dll on Win32
Date Fri, 28 Jan 2005 18:04:28 GMT
On Fri, 28 Jan 2005, Steve Hay wrote:

> I just built libapreq2-2.04_03-dev on Win32 with
> httpd-2.0.52 and perl-5.8.6 (configured as per ActivePerl)
> and I find that all the t/apreq/cgi.t tests (from "nmake
> perl_test") fail with a popup error message saying the
> libapr.dll can't be found.
>
> Simply adding the apache\bin directory (where this DLL is
> located) to my PATH fixed it, but I don't recall having
> seen this behaviour before.
>
> What's going on?  Is this normal?

You shouldn't have to do this - I tried to arrange to have
apache\bin added to the PATH, at least in the current svn
sources. However, I may have broken something - when you run
the perl tests (thru 'nmake perl_test'), I believe that the
   set PATH=....
should be echoed back to the screen - if it is, does the
location of one of the entries in PATH correspond to your
apache\bin directory? It should be the 2nd entry, I
believe.

-- 
best regards,
randy

Mime
View raw message