httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bojan Smojver <bo...@rexursive.com>
Subject Re: plans for 2.04-dev
Date Mon, 30 Aug 2004 02:09:54 GMT
Quoting Stas Bekman <stas@stason.org>:

> No, there are all not required modules. Module::Build is used by
> Apache::Test, if you are using Apache::TestMB (which is not used by
> mod_perl). Data::Flow is used only by developers of mod_perl 2.0. You
> should look for the Makefile.PL requirements, not any use()/require()
> statements you can see in the distribution.

Once again, thanks for letting me know about this. I have found how Red Hat do
this in mod_perl - they use a little script called filter-requires.sh that
hoses the bogus requirements out of perl.req file. I've added all of these to
the list and now mod_perl RPM installs cleanly. Whether it works or not will
have to be determined by someone that actually does know Perl and mod_perl.

In any event, I'll upload the new mod_perl RPMS to the same location once I get
to the box that is allowed to do that. Shouldn't take more than a day.

--
Bojan

Mime
View raw message