httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: [apreq-2] Various test issues
Date Tue, 20 Jul 2004 12:20:34 GMT
On Tue, 20 Jul 2004, Markus Wichitill wrote:

> Randy Kobes wrote:
> > Running the tests as root (for any package) generally casues
> > problems with Apache-Test, for reasons of permissions, as
> > you saw. I don't think there's a general fix yet, apart from
> > running the tests as non-root.
>
> Well, ever since the tests did the chowning to nobody, it worked fine. It's
> just that in this case the test upload files are written to perl/glue (the
> CWD), which isn't owned by nobody, unlike perl/glue/t. Maybe they should be
> moved to t:

That sounds right - thanks.

>
> >>All apreq/cgi.t tests that worked before fail in that case however, since
> >>test_cgi.pl can't be executed due to the lack of mod_cgid in the generated
> >>t/conf/httpd.conf.
>
> > Is mod_cgi (or mod_cgid, if this is for a multi-threaded
> > unix mpm) enabled in your system httpd.conf?  We should
> > probably skip those tests if one of these, as appropriate,
> > isn't available.
>
> mod_cgid is enabled. If tests are run as root, it's included in the
> generated httpd.conf. And I don't see any permissions that would preclude
> the tests from including it when not run as root.

Neither do I - the system httpd.conf is parsed for available
modules, which should find mod_cgi and/or mod_cgid, if
enabled. I'll try to reproduce your problem (although
I'm using mod_cgi - not sure if that makes a difference).

> >>Under Win32, the linkfile part of the upload test needs another :APR open to
> >>work, otherwise the open will fail with permission denied:
>
> > Strange - that worked for me without the patch
>
> Maybe you didn't get a real hardlink but a copy because of a different
> partition or a FAT partition? If it's a real NTFS hardlink, it would make
> sense if the open() needs :APR like the open() in the tempname() test.
>
> > what is your $temp_dir?
>
> C:\\DOKUME~1\\mawic\\Temp, which is on the only partition on this WinXP Home
> system.

That make sense - thanks. I'll apply that patch to use :APR
in a few days, when I return.

-- 
best regards,
randy


Mime
View raw message