httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: Apache::Request
Date Mon, 05 Jul 2004 03:23:07 GMT
On Sun, 4 Jul 2004, Stas Bekman wrote:

> Joe Schaefer wrote:
> > Stas Bekman <stas@stason.org> writes:
> >
> > [...]
> >
> >
> >>why not require a higher ExtUtils::MakeMaker? It's easily
> >>upgradable from CPAN, not requiring a perl upgrade.
> >
> >
> > +1 (no patch from me though).
>
> But where should the requirement come from. I think you need it in the apreq's
>   Makefile.PL, no? mod_perl itself has no such requirement
> and we won't create it. Or should it go into ModPerl::MM?
> In which case it can only be done dynamically from
> ModPerl::MM::WriteMakefile, which won't tell CPAN/CPANPLUS
> about the prerequisites in time. So may be both apreq's
> Makefile.PL and dynamically at ModPerl::MM::WriteMakefile
> is the best fit?
>
> Which version again do we need to require?

I worked backwards on my system - the minimum version of
ExtUtils::MakeMaker *on CPAN* that works for me in
installing pm files into an Apache2/ subdirectory is 6.15.
There may be earlier ones that work, but I couldn't test
them. Here's a patch for apreq-2 that requires this minimum
version (I'm not sure if I got the automake/autoconf all
there):
=============================================================
Index: acinclude.m4
===================================================================
RCS file: /home/cvs/httpd-apreq-2/acinclude.m4,v
retrieving revision 1.22
diff -u -r1.22 acinclude.m4
--- acinclude.m4	22 Jun 2004 03:45:56 -0000	1.22
+++ acinclude.m4	5 Jul 2004 03:20:01 -0000
@@ -68,6 +68,9 @@
             if test -z "`$prereq_check Apache::Test`"; then
                 AC_MSG_ERROR([Bad Apache::Test version])
             fi
+            if test -z "`$prereq_check ExtUtils::MakeMaker`"; then
+                AC_MSG_ERROR([Bad ExtUtils::MakeMaker version])
+            fi
         fi

         AC_CONFIG_COMMANDS_POST([test "x$PERL_GLUE" != "xno" &&
Index: Makefile.PL
===================================================================
RCS file: /home/cvs/httpd-apreq-2/Makefile.PL,v
retrieving revision 1.8
diff -u -r1.8 Makefile.PL
--- Makefile.PL	7 Nov 2003 20:05:19 -0000	1.8
+++ Makefile.PL	5 Jul 2004 03:20:01 -0000
@@ -39,6 +39,7 @@
         $opts .= "--enable-perl-glue ";
         test_prereq "mod_perl";
         test_prereq "Apache::Test";
+        test_prereq "ExtUtils::MakeMaker";
     }

     delete @opts{@flags};
Index: build/version_check.pl
===================================================================
RCS file: /home/cvs/httpd-apreq-2/build/version_check.pl,v
retrieving revision 1.15
diff -u -r1.15 version_check.pl
--- build/version_check.pl	2 Jul 2004 16:18:37 -0000	1.15
+++ build/version_check.pl	5 Jul 2004 03:20:01 -0000
@@ -20,6 +20,11 @@
     $Apache::Test::VERSION;
 }

+sub mm_version {
+    require ExtUtils::MakeMaker;
+    $ExtUtils::MakeMaker::VERSION;
+}
+
 sub mp2_version {
     eval {
         require Apache2;
@@ -53,6 +58,7 @@
                              comment => "Win32 requires version 1.06"    },
   "ExtUtils::XSBuilder" => { version => "0.23",    test => \&xsb_version },
               mod_perl  => { version => "1.99_15", test => \&mp2_version },
+  "ExtUtils::MakeMaker" => { version => "6.15",    test => \&mm_version  },
                 );

 sub print_prereqs ($$) {

=============================================================

-- 
best regards,
randy

Mime
View raw message