httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: [apreq-2] make test fails
Date Fri, 02 Jul 2004 05:19:51 GMT
On Thu, 1 Jul 2004, Joe Schaefer wrote:

> Randy Kobes <randy@theoryx5.uwinnipeg.ca> writes:
>
> > With the current cvs, on Win32 I get a failure in the
> > top-level 'make test' (not the perl glue):
>
> [...]
>
> > Failed tests in Param:
> > 1) params_as: expected
> > ---->
> > 1, 2
> > <----
> > but saw
> > ---->
> > 1, 2, 1, 2, 1, 2
> > <----
>
> Just committed this patch:
>
> Index: t/params.c
> ===================================================================
> RCS file: /home/cvs/httpd-apreq-2/t/params.c,v
> retrieving revision 1.12
> diff -u -r1.12 params.c
> --- t/params.c  28 Jun 2004 04:50:14 -0000      1.12
> +++ t/params.c  2 Jul 2004 01:44:14 -0000
> @@ -56,6 +56,9 @@
>  static void params_as(CuTest *tc)
>  {
>      const char *val;
> +    apr_array_header_t *arr;
> +    arr = apreq_params_as_array(p,r,"a");
> +    CuAssertIntEquals(tc,2,arr->nelts);
>      val = apreq_params_as_string(p,r,"a",APREQ_JOIN_AS_IS);
>      CuAssertStrEquals(tc,"1, 2", val);
>  }
>
> What do you see now?

Still a failure :(
======================================================
	cd D:\unzipped\HTTPD-~2\win32\libs && testall.exe -v
All APREQ Tests:
    Version:                  .....
    Cookie:                   ....
    Param:                    ..F.
    Parsers:                  ...

16 tests run:  15 passed, 1 failed, 0 not implemented.

Failed tests in Param:
1) params_as: expected <2> but was <4>

===========================================================

I take it it's not a problem on linux?

-- 
best regards,
randy

Mime
View raw message