httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Wichitill <ma...@gmx.de>
Subject Trying to test current apreq2 CVS
Date Fri, 02 Jul 2004 08:53:31 GMT
Hi,

I tried to compile the latest apreq2 CVS on Linux to test $upload->fh/size.

First I tried to compile it for mod_perl 1.99_14 (Apache 2.0.50 Worker, Perl
5.8.3), which failed since that version doesn't contain the required
modperl_common_util.h. Maybe that's correct, but I thought I'll mention it
since the docs still say that _09 is required.

So I compiled the current mod_perl CVS first, which copied
modperl_common_util.h into apache2/include. However only after I manually
copied modperl_common_types.h into apache2/include did apreq's Perl glue
compile and test ok.

When I try to upload a file in my webapp, I get "[error] Can't locate
auto/Apache/Request/upload.al in @INC" though. I don't think I ever saw any
of those .al files with MP.

BTW, does the APR::PerlIO-based $upload->fh require Perl 5.8?

Mime
View raw message