httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Wichitill <ma...@gmx.de>
Subject Re: [apreq-2] Various test issues
Date Tue, 20 Jul 2004 04:10:40 GMT
Randy Kobes wrote:
> Running the tests as root (for any package) generally casues
> problems with Apache-Test, for reasons of permissions, as
> you saw. I don't think there's a general fix yet, apart from
> running the tests as non-root.

Well, ever since the tests did the chowning to nobody, it worked fine. It's 
just that in this case the test upload files are written to perl/glue (the 
CWD), which isn't owned by nobody, unlike perl/glue/t. Maybe they should be 
moved to t:

Index: glue/perl/t/apreq/upload.t
===================================================================
RCS file: /home/cvspublic/httpd-apreq-2/glue/perl/t/apreq/upload.t,v
retrieving revision 1.1
diff -u -r1.1 upload.t
--- glue/perl/t/apreq/upload.t	12 Jul 2004 13:10:14 -0000	1.1
+++ glue/perl/t/apreq/upload.t	20 Jul 2004 03:39:24 -0000
@@ -23,7 +23,7 @@
      my $url = ( ($name =~ /\.pod$/) ?
          "getfiles-perl-pod/" : "/getfiles-binary-" ) . $name;
      my $content = GET_BODY_ASSERT($url);
-    my $path = File::Spec->catfile($cwd, $name);
+    my $path = File::Spec->catfile($cwd, "t", $name);
      open my $fh, ">", $path or die "Cannot open $path: $!";
      binmode $fh;
      print $fh $content;
@@ -33,7 +33,7 @@
  eval {require Digest::MD5;};
  my $has_md5 = $@ ? 0 : 1;

-foreach my $file( map {File::Spec->catfile($cwd, $_)} @names) {
+foreach my $file( map {File::Spec->catfile($cwd, "t", $_)} @names) {
      my $size = -s $file;
      my $cs = $has_md5 ? cs($file) : 0;
      my $basename = File::Basename::basename($file);


>>All apreq/cgi.t tests that worked before fail in that case however, since
>>test_cgi.pl can't be executed due to the lack of mod_cgid in the generated
>>t/conf/httpd.conf.

> Is mod_cgi (or mod_cgid, if this is for a multi-threaded
> unix mpm) enabled in your system httpd.conf?  We should
> probably skip those tests if one of these, as appropriate,
> isn't available.

mod_cgid is enabled. If tests are run as root, it's included in the 
generated httpd.conf. And I don't see any permissions that would preclude 
the tests from including it when not run as root.


>>Under Win32, the linkfile part of the upload test needs another :APR open to
>>work, otherwise the open will fail with permission denied:

> Strange - that worked for me without the patch

Maybe you didn't get a real hardlink but a copy because of a different 
partition or a FAT partition? If it's a real NTFS hardlink, it would make 
sense if the open() needs :APR like the open() in the tempname() test.

> what is your $temp_dir?

C:\\DOKUME~1\\mawic\\Temp, which is on the only partition on this WinXP Home 
system.


Mime
View raw message