httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Apache::Request
Date Mon, 05 Jul 2004 02:04:29 GMT
Joe Schaefer wrote:
> Stas Bekman <stas@stason.org> writes:
> 
> [...]
> 
> 
>>why not require a higher ExtUtils::MakeMaker? It's easily
>>upgradable from CPAN, not requiring a perl upgrade.
> 
> 
> +1 (no patch from me though).

But where should the requirement come from. I think you need it in the apreq's 
  Makefile.PL, no? mod_perl itself has no such requirement and we won't create 
it. Or should it go into ModPerl::MM? In which case it can only be done 
dynamically from ModPerl::MM::WriteMakefile, which won't tell CPAN/CPANPLUS 
about the prerequisites in time. So may be both apreq's Makefile.PL and 
dynamically at ModPerl::MM::WriteMakefile is the best fit?

Which version again do we need to require?

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message