httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Trying to test current apreq2 CVS
Date Fri, 02 Jul 2004 16:43:39 GMT
Joe Schaefer wrote:
[...]
>>BTW, does the APR::PerlIO-based $upload->fh require Perl 5.8?
> 
> 
> Don't know how that works- Stas?

The apr_file_t => GLOB{IO} filehandle conversion should work with 5.6 and 5.8 
I believe.

APR::PerlIO works only with 5.8.x build with:

perl -V:useperlio
useperlio='define';

But can also be checked dynamically doing:

   use APR::PerlIO ();
   die "This Perl build doesn't support PerlIO layers"
       unless APR::PerlIO::PERLIO_LAYERS_ARE_ENABLED;

There is the manpage:
http://perl.apache.org/docs/2.0/api/APR/PerlIO.html#APR__PerlIO__PERLIO_LAYERS_ARE_ENABLED

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message