httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <da...@kineticode.com>
Subject Re: Issues with CPAN releases
Date Tue, 22 Jun 2004 19:18:22 GMT
On Jun 22, 2004, at 11:53 AM, Randy Kobes wrote:

>>>    Apache::Request => '>= 1.2, != 1.5, < 2.0',
>>
>> OK, thanks.  This info belongs in the README (and FAQ as
>> well, I suppose).
>
> One issue unfortunately that remains that Stas mentioned is
> installation within the CPAN/CPANPLUS shells. These use the
> CPAN indices, which map module names to distributions. Thus,
> for example, now Apache::Request is associated with
> libapreq-1.3, with CPAN version 1.3. But when libapreq2 is
> released (and indexed by PAUSE), it will register
> Apache::Request of libapreq2, and if the version of this
> Apache::Request is higher than 1.3, installing
> Apache::Request will install libapreq2.

Not with the above version requirement string. Or am I misunderstanding 
you?

Of course, the simplest solution would be to rename it Apache2::Request.

Regards,

David


Mime
View raw message