httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: It's time to get 2.03-dev out
Date Sun, 06 Jun 2004 16:57:41 GMT
Martin Nilsson <martin@gneto.com> writes:

> I have to comment out the versioning checks in buildconf when running
> on FreeBSD where the libtool/autoconf/automake tools are named after
> their version. 

Sorry, I don't know how to resolve this issue.  Hopefully the FreeBSD
port of these tools will eventually include appropriate symlinks or some 
other work-around.

> I have to change AM_PROG_LIBTOOL in configure.ac to AC_PROG_LIBTOOL to
> make it work otherwise I get:
> 
> platon# aclocal14
> aclocal: configure.ac: 19: macro `AM_PROG_LIBTOOL' not found in library
> 
> Now buildconf works but configure does not:

You also need to modify the aclocal call in buildconf, because libtool.m4
isn't where aclocal expects to find it.  Someone has been kind enough 
to provide me with a FreeBSD shell, and we learned that passing the
directory name (/usr/share/aclocal?) to aclocal with "-I" seems to fix 
this (along with using gmake instead of make).  However, we got stuck 
getting Apache::Test to compile the c-modules correctly and bring up an
httpd daemon to test.

If there's a simple way to resolve these FreeBSD build issues, I'd love
to include that in 2.03-dev.

-- 
Joe Schaefer


Mime
View raw message