httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [mp2] APR w/o mod_perl
Date Thu, 17 Jun 2004 13:57:40 GMT
Joe Schaefer wrote:
> Stas Bekman <stas@stason.org> writes:
> 
> [...]
> 
> 
>>Why are you using BuildMM and not MM for libapreq? BuildMM is for
>>mod_perl only or do you mean something else?
> 
> 
> It's the .so's (like APR/Pool/Pool.so) in mp2 that need to be linked to 
> libapr.  apreq's .so's are already linked correctly.

Ah, OK, so it's mp2's APR-stand-alone issue. I suppose Randy handles that at 
the moment.

>>>  2) Expose APR::General::initialize in xs/maps/apr_functions.map
>>>     and call it at the top of the (generated) test_cgi.pl script.
>>
>>That shouldn't be the case if you 'use APR', which does that thing already. I
>>was thinking to have all APR:: modules load APR.pm internally.
>  
> That's what I was expecting to happen, but Randy's cgi.t test was
> segfaulting for me in apr_pool_create without this change.

Could you possibly contribute a test for modperl-2.0/t/apr-ext/, that you get 
that segfault with? Once we have it then it's easier to see why this doesn't work.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message