httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: 2.03-dev-rc3 (was Re: 5.6.1 segfaults during perl tests)
Date Fri, 11 Jun 2004 13:31:49 GMT
> Folks,
> 
>   Please try this bundle and report back,
> especially if you encountered problems testing
> a previous candidate.
> 
>   http://cvs.apache.org/~joes/libapreq2-2.03-dev-rc3.tar.gz
> 
> After a few +1s we'll let the modperl list take
> a crack at it.

I am getting warnings with fedora core 1 (gcc 3.3.2) on 2.0.49 and 2.0 dev.

Apache__Request.h: In function `apreq_xs_upload_slurp':
Apache__Request.h:203: warning: passing arg 3 of `apr_brigade_flatten' from
incompatible pointer type

since I build with -Werror this stops things for me (and -Werror is a good
idea for us developers anyway, since stas will inevitably pick up on it and
let you know ;)

apr_brigade_flatten takes an apr_size_t while apr_brigade_length takes an
apr_off_t (go figure).  anyway, I tried fixing it by declaring both types
and using some casts so it compiles, but I get core dumps left and right in
the tests.  so sorry, no patch from me atm.

--Geoff

Mime
View raw message