httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Nilsson <mar...@gneto.com>
Subject Re: 2.03-dev-rc1 available
Date Thu, 10 Jun 2004 20:26:45 GMT
Joe Schaefer wrote:
> Martin Nilsson <martin@gneto.com> writes:
>>This would not be necessary if $Config{make] was gmake instead of
>>make. This seems to be a problem with Apache::Test not libapreq!
> 
> 
> Tough call, since Apache::Test is using the same "make" that
> perl did.  

amd perl 5.8 is compilable with the standard BSD make.

> Please try the following patch if possible (I think 
> you need to run buildconf, or at least reconfigure with 
> --enable-maintainer-mode).

I can't run buildconf, I wasn't able to sort out the version differences.

> 
> Index: env/Makefile.am

These patches won't apply, if I apply them manually I must run buildconf.

I pasted the new contents into the created Makefile instead.

> Index: env/t/TEST.PL

The patches applied cleanly.

I found another extra.config file that needs LockFile path in 
glue/perl/t/conf/extra.conf.in

Without it httpd won't start as the default location is in /var/log 
where the test user doesn't have write access.

After this both tests completes successfully!

Can you apply the patches and roll a -rc2 for final testing?

	/Martin


/usr/local/sbin/httpd -d /home/martin/libapreq2-2.03-dev/env/t -f 
/home/martin/libapreq2-2.03-dev/env/t/conf/httpd.conf -D APACHE2
using Apache/2.0.49 (prefork MPM)

waiting 60 seconds for server to start: ...
waiting 60 seconds for server to start: ok (waited 2 secs)
server localhost:8529 started
[  debug] Matched Apache revision Apache/2.0.49 2
t/big_request....ok
t/cgi............ok
t/cookie.........ok
t/request........ok
All tests successful.
Files=4, Tests=71,  8 wallclock secs ( 3.59 cusr +  0.54 csys =  4.13 CPU)
[warning] server localhost:8529 shutdown
gmake[1]: Leaving directory `/home/martin/libapreq2-2.03-dev/env'
cd glue/perl; gmake test
gmake[1]: Entering directory `/home/martin/libapreq2-2.03-dev/glue/perl'
gmake[2]: Entering directory `/home/martin/libapreq2-2.03-dev/glue/perl/xs'
gmake[3]: Entering directory 
`/home/martin/libapreq2-2.03-dev/glue/perl/xs/Apache'
gmake[4]: Entering directory 
`/home/martin/libapreq2-2.03-dev/glue/perl/xs/Apache/Cookie'
gmake[4]: Leaving directory 
`/home/martin/libapreq2-2.03-dev/glue/perl/xs/Apache/Cookie'
gmake[4]: Entering directory 
`/home/martin/libapreq2-2.03-dev/glue/perl/xs/Apache/Request'
gmake[4]: Leaving directory 
`/home/martin/libapreq2-2.03-dev/glue/perl/xs/Apache/Request'
gmake[3]: Leaving directory 
`/home/martin/libapreq2-2.03-dev/glue/perl/xs/Apache'
gmake[2]: Leaving directory `/home/martin/libapreq2-2.03-dev/glue/perl/xs'
/usr/local/bin/perl5.8.4 -Iblib/arch/Apache2 -Iblib/lib/Apache2 \
t/TEST -clean
APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT= 
APACHE_TEST_USER= APACHE_TEST_APXS= \
/usr/local/bin/perl5.8.4 -Iblib/arch/Apache2 -Iblib/lib/Apache2 \
t/TEST -bugreport -verbose=0
/usr/local/sbin/httpd -d /home/martin/libapreq2-2.03-dev/glue/perl/t -f 
/home/martin/libapreq2-2.03-dev/glue/perl/t/conf/httpd.conf -D APACHE2
using Apache/2.0.49 (prefork MPM)

waiting 60 seconds for server to start: ...
waiting 60 seconds for server to start: ok (waited 3 secs)
server localhost:8529 started
t/apreq/big_input....ok
t/apreq/cookie.......ok
t/apreq/inherit......ok
t/apreq/request......ok
All tests successful.
Files=4, Tests=35,  7 wallclock secs ( 5.72 cusr +  0.69 csys =  6.41 CPU)
[warning] server localhost:8529 shutdown
gmake[1]: Leaving directory `/home/martin/libapreq2-2.03-dev/glue/perl'

Mime
View raw message