httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Nilsson <mar...@gneto.com>
Subject Re: 2.03-dev-rc1 available
Date Thu, 10 Jun 2004 18:13:01 GMT
FreeBSD 4.10 test status:

using Apache/2.0.49 (prefork MPM)

waiting 60 seconds for server to start: ..
waiting 60 seconds for server to start: ok (waited 1 secs)
server localhost:8529 started
[  debug] Matched Apache revision Apache/2.0.49 2
t/big_request....ok
t/cgi............ok
t/cookie.........ok
t/request........ok
All tests successful.
Files=4, Tests=71,  7 wallclock secs ( 3.62 cusr +  0.51 csys =  4.12 CPU)
[warning] server localhost:8529 shutdown
gmake[1]: Leaving directory `/tmp/libapreq2-2.03-dev/env'



I have changed the following:
env/t/TEST.PL added these functions.

sub cmodules_makefile_vars {
     return <<EOF;
MAKE = gmake
EOF
}

sub cmodules_make {
     my $self = shift;
     my $targ = shift || 'all';

     my $cmd = "cd $self->{cmodules_dir} && gmake $targ";
     debug $cmd;
     system $cmd;
     if ($?) {
         die "Failed to build c-modules";
     }
}

This would not be necessary if $Config{make] was gmake instead of make. 
This seems to be a problem with Apache::Test not libapreq!

Added LockFile path to: env/t/conf/extra.conf.in
LockFile @ServerRoot@/logs/accept.lock

Now it's time to actually try to use libapreq together with mod_perl2 :-)

Thanks for the help and all work you've put into libapreq2


	/Martin


Mime
View raw message