httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Sabol" <sa...@alderaan.gsfc.nasa.gov>
Subject Re: It's time to get 2.03-dev out
Date Tue, 08 Jun 2004 05:24:48 GMT
Joe Schaefer wrote:
> Please test current cvs and report/fix any build problems;  I plan
> to start the release process in a few days.

My configuration:

dual AMD processors
Linux Red Hat 7.3 + SMP + latest kernel security patches
Apache 2.0.49
mod_perl 1.99_13
Perl 5.6.1
libtool 1.4.2
autoconf 2.59
automake 1.8.2

I just tested a build from the CVS sources. Before starting the build, I blew
away my httpd-apreq-2 directory and checked out a fresh copy from CVS.
Everything seemed to work fine until I did a "make test". It seems
env/.libs/mod_apreq.so was never created.

----
waiting 60 seconds for server to start: .Syntax error on line 12 of /Home/home2/sabol/work/httpd-apreq-2/env/t/conf/httpd.conf:
Cannot load /Home/home2/sabol/work/httpd-apreq-2/env/.libs/mod_apreq.so into server: /Home/home2/sabol/work/httpd-apreq-2/env/.libs/mod_apreq.so:
cannot open shared object file: No such file or directory
[  error] 
server has died with status 1 (t/logs/error_log wasn't created, start the server in the debug
mode)
----

% ls -l env/.libs/
total 216
-rwxr-xr-x    1 sabol    man         75021 Jun  8 00:43 mod_apreq*
-rw-r--r--    1 sabol    man         72010 Jun  8 00:43 mod_apreq.a
lrwxrwxrwx    1 sabol    man            15 Jun  8 00:43 mod_apreq.la -> ../mod_apreq.la
-rw-r--r--    1 sabol    man           968 Jun  8 00:43 mod_apreq.lai
-rwxr-xr-x    1 sabol    man         53638 Jun  8 00:47 test_cgi*

I think this is the relevant portion of the build log:

make[1]: Entering directory `/Home/home2/sabol/work/httpd-apreq-2/env'
source='mod_apreq.c' object='mod_apreq.lo' libtool=yes \
depfile='.deps/mod_apreq.Plo' tmpdepfile='.deps/mod_apreq.TPlo' \
depmode=gcc /bin/sh ../depcomp \
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -I/usr/wwwserver/apache.2.0.49/include
 -I/usr/wwwserver/apache.2.0.49/include   -I/usr/wwwserver/apache.2.0.49/include     -g -O2
-c -o mod_apreq.lo mod_apreq.c
rm -f .libs/mod_apreq.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -I/usr/wwwserver/apache.2.0.49/include -I/usr/wwwserver/apache.2.0.49/include
-I/usr/wwwserver/apache.2.0.49/include -g -O2 -c mod_apreq.c -Wp,-MD,.deps/mod_apreq.TPlo
 -fPIC -DPIC -DPIC -o mod_apreq.o
mv -f mod_apreq.o .libs/mod_apreq.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -I/usr/wwwserver/apache.2.0.49/include -I/usr/wwwserver/apache.2.0.49/include
-I/usr/wwwserver/apache.2.0.49/include -g -O2 -c mod_apreq.c -Wp,-MD,.deps/mod_apreq.TPlo
-o mod_apreq.o >/dev/null 2>&1
mv -f .libs/mod_apreq.lo mod_apreq.lo
/bin/sh ../libtool --mode=link gcc  -g -O2   -o mod_apreq.la  -export-dynamic -module -avoid-version
-rpath `/usr/wwwserver/apache/bin/apxs -q LIBEXECDIR` mod_apreq.lo  ../src/libapreq2.la  /usr/wwwserver/apache.2.0.49/lib/libapr-0.la
-lrt -lcrypt -lnsl  -lpthread -ldl  /usr/wwwserver/apache.2.0.49/lib/libaprutil-0.la -lgdbm
-ldb1 -lexpat
libtool: link: warning: `/usr/lib//libgdbm.la' seems to be moved
rm -fr .libs/mod_apreq.la .libs/mod_apreq.* .libs/mod_apreq.*
gcc -shared  mod_apreq.lo  -Wl,--rpath -Wl,/home2/sabol/work/httpd-apreq-2/src/.libs -Wl,--rpath
-Wl,/usr/wwwserver/apache.2.0.49/lib -Wl,--rpath -Wl,/usr/wwwserver/apache.2.0.49/lib  -L/usr/lib/
-L/usr/wwwserver/apache.2.0.49/lib ../src/.libs/libapreq2 /usr/wwwserver/apache.2.0.49/lib/libapr-0.so
-lrt -lcrypt -lnsl -lpthread -ldl /usr/wwwserver/apache.2.0.49/lib/libaprutil-0.so /usr/lib/libgdbm.so
-ldb1 /usr/wwwserver/apache.2.0.49/lib/libexpat.so   -Wl,-soname -Wl,mod_apreq -o .libs/mod_apreq
ar cru .libs/mod_apreq.a  mod_apreq.o 
ranlib .libs/mod_apreq.a
creating mod_apreq.la
(cd .libs && rm -f mod_apreq.la && ln -s ../mod_apreq.la mod_apreq.la)
make[1]: Leaving directory `/Home/home2/sabol/work/httpd-apreq-2/env'

Mime
View raw message