httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: Missing submit button if after a file field
Date Fri, 09 Apr 2004 12:46:40 GMT
"Rob Mueller" <robm@fastmail.fm> writes:

[...]

> If I click the first button, in the log I see:
> 
> ------------jZLJfj7sG9kLeKXzCBVikO7gXcwytA8ahRtMA1FQAxjmGHkSSF9AbEp
> Content-Disposition: form-data; name="somename"
> 
> Click
> ------------jZLJfj7sG9kLeKXzCBVikO7gXcwytA8ahRtMA1FQAxjmGHkSSF9AbEp
> Content-Disposition: form-data; name="FMC-UploadFile1"; filename=""
> 
> ------------jZLJfj7sG9kLeKXzCBVikO7gXcwytA8ahRtMA1FQAxjmGHkSSF9AbEp--
> 
> No problem. If I click the second button, in the log I see:
> 
> ------------bQaJLMV8JU2DxyhdPfNYApBF5BDgYSk7tIRCewKvOK6LInxiTKEb8Pq
> Content-Disposition: form-data; name="FMC-UploadFile1"; filename=""
> 
> ------------bQaJLMV8JU2DxyhdPfNYApBF5BDgYSk7tIRCewKvOK6LInxiTKEb8Pq
> Content-Disposition: form-data; name="somename"
> 
> Click
> ------------bQaJLMV8JU2DxyhdPfNYApBF5BDgYSk7tIRCewKvOK6LInxiTKEb8Pq--
> 
> Also apparently no problem, the actual data is there. 

I suspect that libapreq isn't able to handle the empty file block
that Konqueror is generating.  I'll check the RFC, but my first
reaction to your posted data is that there's an "\r\n" missing in 
Konqueror's output.  Mozilla 0.97 had the same problem; recall

  http://marc.theaimsgroup.com/?l=apache-modperl&m=101295988431701&w=2

-- 
Joe Schaefer


Mime
View raw message