httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Test build w/ Perl glue for CGI
Date Fri, 16 Apr 2004 19:52:36 GMT
Joe Schaefer wrote:
> Geoffrey Young <geoff@modperlcookbook.org> writes:
> 
> 
>>Joe Schaefer wrote:
> 
> 
> [...]
> 
> 
>>>The strange thing is that the test script
>>>at glue/perl/t/cgi-bin/test_cgi.pl seems
>>>to work fine on Debian when I run it from 
>>>the command line, but the Apache::Test test 
>>>suite hangs after completing the first 7 
>>>tests successfully.
>>
>>I see the same thing, no ideas though.
>>
>>btw, the test_cgi.pl script has a hard-coded perl for your system in
>>it. I'd suggest using t_write_perl_script() for the generation of all
>>cgi scripts (not just this one).  patch for this one only attached.
> 
> 
> Thanks!  A patched package is available at
> 
>   http://cvs.apache.org/~joes/libapreq2-20040416.tar.gz
> 
> Folks, please try this one.  If we can't figure out why
> the cgi tests are hanging, maybe we should just skip
> tests 8-31 for now and commit the test script (glue/perl/t/cgi.t)
> to cvs.

Give it some time to timeout, it's not 8-31 that fail. It fails on 8th (15 
keys), but succeeds on 9th (26 keys) and next time it hangs on 14th, etc.

The error is:

[Fri Apr 16 12:40:24 2004] [error] [client 127.0.0.1] Premature end of script 
headers: test_cgi.pl

Sounds like a buggy code. I didn't dig into it.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message