httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric J. Hansen" <ehan...@worldmachine.com>
Subject RE: Problem with posting lots of data
Date Wed, 25 Feb 2004 02:55:10 GMT
I've tried this on my dev machine, and found exactly the same problem.  Printing
the decoded values reveals that after parameter 442, the list "wraps",
and the param list starts again at the first element. i.e., value.441,
value.442, value.1, value.2, ...

FYI, here's my platform:

Apache 2.0.48
mod_perl/1.99_11
Perl/v5.8.2
mod_ssl/2.0.48
OpenSSL/0.9.7c
libapreq2-2.02-dev

Just like Paul, I'm only seeing this problem under mod_ssl.  Under non-SSL I was
able to pass many 1,000's of parameters with nary a hitch.

-Eric



> -----Original Message-----
> From: Paul G. Weiss [mailto:paul@weiss.name] 
> Sent: Tuesday, February 24, 2004 5:48 PM
> To: apreq-dev@httpd.apache.org
> Subject: Problem with posting lots of data
> 
> 
> I have a weird problem that shows up when posting lots of 
> data through  
> libapreq2.  I've tried this both with libapreq2-2.02-dev and 
[...]
> But for n>442 the numbers don't match.
> 
> That isn't all.  It works fine through http (as long as n < 
> FIELD_LIMIT),  
> but fails through https.  So you would think that the problem 
> is with  
> mod_ssl/openssl.  However, if you use CGI instead of 
> Apache::Request (see  
> below - comment out the Apache::Request line and uncomment 
> the CGI line),  
> it works fine, even through https!  This tells me that it isn't  
> mod_ssl/openssl alone, but in the interaction between it and 
> libapreq2,  
> perhaps some difference in how the data is buffered?
> 
> Can anyone confirm this?
> I'm using
> 	Apache 2.0.48
> 	mod_perl/1.99_12
> 	Perl/v5.8.1
> 	mod_ssl/2.0.48
> 	OpenSSL/0.9.7a
> 


Mime
View raw message