httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: MM Patch
Date Fri, 24 Oct 2003 05:04:38 GMT
David Wheeler <david@kineticode.com> writes:

> Hi All,
> 
> I was just building apreq 1.3 on a new box with Perl 5.8.1, and ran
> into a problem:
> 
> [Thu Oct 23 21:09:30 2003] [error] Undefined subroutine
> &TestApReq::big_input::handler
>   called.
> 
> Fortunately, a little Googling led me to the answer:
> 
>    http://marc.theaimsgroup.com/?l=apreq-dev&m=105965131008577&w=2
> 
> Looking in CVS, it doesn't look like this patch has been applied
> yet. Does this mean that the current version of apreq is broken for
> Perl 5.8.1 until the patch gets applied and 1.4 is released?

I hope not, since this problem was the main reason for 1.3.
I applied Michael Schwern's patch instead of Stas' since I was 
concerned that Stas' patch would break picky platforms like OSX, 
whereas Michael's patch shouldn't have.

OTOH empirical evidence speaks much louder than idle speculation. 
If you're willing to speak on the veracity of Stas' patch for 
OSX for 5.8.*, I have no objections to seeing it applied to cvs.
Platform details would come in handy, since we've had trouble
reproducing these build bugs in the past (especially if you have 
some libapreq.so's floating around from old "configure" installs-
running "ldd" on the failing Request.so's might help us figure out
which libraries are being linked in).

-- 
Joe Schaefer


Mime
View raw message