httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: Problem installing Apache::Request
Date Sat, 04 Oct 2003 14:39:01 GMT
Leon Sonntag <leon@iwa-solutions.com> writes:

> Hopefully this is the correct group for this....If not I would
> appreciate guidence.

It's as good a place as any, although the mod-perl user list might
be a slightly better choice.

> I am trying to install several Perl modules on my Apache 1.3.28 server.
> 
>    This is on a Fresh install of Redhat 8.  This time without the redhat
> updates.

I run RH 8 (with all updates, but I never use their apache rpm's), so 
hopefully I should be able to help...

>    I have Perl 5.8.0 loaded from the Redhat RPMs and Perl 5.8.1
> compiled from source.
> 
>    I am trying, using CPAN, to load Apache::Request.  It needs
> Apache::Test. When Apache::Test tries to install it fails at the "make
> test".  Digging deeper, I found that when the test program tries to do
> a GET, on anything, it is getting "access denied".  I can access all
> pages on the server through a browser so I'm not clear on what is
> causing the problem. 

If you downloaded libapreq from CPAN as "root", there's a very good
chance that libapreq is sitting in a directory for which only root
has access.  The Apache::Test suite we use now does not work in this 
setting.

Try downloading, building, and testing libapreq as a non-root
user, and see if you still see problems with the tests.

-- 
Joe Schaefer


Mime
View raw message