httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Hay <steve....@uk.radan.com>
Subject [libapreq-2] Test failure on Win32
Date Wed, 17 Sep 2003 14:01:52 GMT
Hi,

I get the following test failure when running "nmake test" on Win32 
(Apache 2.0.47, Perl 5.8.1 @ 21233, mod_perl 2 CVS):

All APREQ Tests:
Cookie: ....
Param: ...
Parsers: .F

9 tests run: 8 passed, 1 failed, 0 not implemented.

Failed tests in Parsers:
1) parse_multipart: expected
---->
... contents of file1.txt ...
<----
but saw
---->
... contents of file1.txt 
...???????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????????????????????????????????????²²²²
<----

Looks like something didn't get null-terminated properly?

I also find that that I can't install anything using the makefile - 
"nmake install" just says "'install' is up-to-date". And there doesn't 
seem to be a "perl_install" target at all on Win32.

- Steve


Mime
View raw message