httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Nandor <pu...@pobox.com>
Subject Re: libapreq failures with 1.2 and Mac OS X Server
Date Fri, 08 Aug 2003 17:03:07 GMT
At 09:46 -0700 2003.08.08, Stas Bekman wrote:
>check your httpd, whether it has these symbols. On my setup:
>
>nm /home/httpd/httpd_perl/bin/httpd | grep sv2request_rec
>080944f6 T sv2request_rec
>
>if you don't have them, it's probably not the apreq's fault.
>
>the sv2request_rec symbol originates from:
>
>nm ../apache-1.3/src/modules/perl/perl_util.lo | grep sv2req
>0000049b T sv2request_rec
>
>can you see it?

Not in httpd, but in perl_util.o.

[pudge@dewey pudge]$ nm /usr/local/apache/sbin/httpd | grep sv2req
[pudge@dewey pudge]$ nm
/usr/local/src/apache_1.3.28/src/modules/perl/perl_util.o | grep sv2req
000002c0 T _sv2request_rec



>I can see that perl_util.lo from your log links to libperl.a:
>
>ar crv libperl.a mod_perl.o perlxsi.o perl_config.o perl_util.o perlio.o
>mod_perl_opmask.o Apache.o Constants.o ModuleConfig.o Log.o URI.o Util.o
>Connection.o Server.o File.o Table.o
>
>so you should also see it in libperl.a (check that you do), which eventually
>gets linked to httpd:

Yep.

[pudge@dewey pudge]$ nm
/usr/local/src/apache_1.3.28/src/modules/perl/libperl.a | grep sv2req
000002c0 T _sv2request_rec
         U _sv2request_rec
         U _sv2request_rec
         U _sv2request_rec
         U _sv2request_rec
         U _sv2request_rec
         U _sv2request_rec

But yet it still doesn't get into the httpd ...

OK, this is messed up:

[pudge@dewey mod_perl-1.28]$ nm /usr/local/apache/sbin/httpd | grep sv2req
[pudge@dewey mod_perl-1.28]$ nm /usr/local/src/apache_1.3.28/src/httpd |
grep sv2req
0000a5b8 T _sv2request_rec
[pudge@dewey mod_perl-1.28]$ ls -l /usr/local/apache/sbin/httpd
-rwxr-xr-x  1 root  wheel  756864 Aug  8 09:57 /usr/local/apache/sbin/httpd
[pudge@dewey mod_perl-1.28]$ ls -l /usr/local/src/apache_1.3.28/src/httpd
-rwxr-xr-x  1 root  wheel  812060 Aug  8 09:57
/usr/local/src/apache_1.3.28/src/httpd

This line is somehow stripping part of the file out?  Could that be right?
 ./src/helpers/install.sh -c -m 755 -s ./src/httpd /usr/local/apache/sbin/httpd

If I manually copy instead of running install.sh, then go back to libapreq
and make test, it works.

Durnit, can someone explain what is going on here in the mod_perl/Apache
install?  :)  Thanks.


>Also I'm not sure why did you have to install libapreq c lib separately,
>purphaps there is some sort of collision here. do you use it elsewhere,
>besides mod_perl?

libapreq's INSTALL.MacOSX said to do it that way.



>when you were testing mod_perl, you've got:
>dyld: ../apache_1.3.28/src/httpd can't open library:
>/usr/local/lib/libapreq.1.dylib  (No such file or directory, errno = 2)
>
>Have you tried nuking any references to libapreq, and then installing only via
>'perl Makefile.PL ...'? instead of doing:

That was because I had previously installed libapreq, so mod_perl tried to
test with it.

-- 
Chris Nandor                      pudge@pobox.com    http://pudge.net/
Open Source Development Network    pudge@osdn.com     http://osdn.com/

Mime
View raw message