httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose.auguste-etie...@cgss-guyane.fr
Subject [AIX 4.3.3] perl 5.6.1 + mod_perl 1.27 + apache 1.27 + libapreq 1.2 + HTML::Mason 1.22 OK
Date Mon, 25 Aug 2003 12:05:02 GMT
Hi everybody,

since the issue deals with mod_perl1, libapreq1 and Mason,
I've chosen to cross-post.

After spending hours trying to build various libapreq versions with no
sucess,
googling for a solution,

I found out that the problems seems to be that the symbols cannot be found
in the .exp,
the .exp file being the httpd.exp

I got the clue from

http://www.mail-archive.com/modperl@apache.org/msg34607.html

so I try to build with

perl Makefile.PL \
    APACHE_SRC=../apache_1.3.27/src \
    DO_HTTPD=1 \
    USE_APACI=1 \
    EVERYTHING=1 \
    APACI_ARGS='--enable-module=so'

make

make test

make install

ant it worked fine for me.

>From there I succesfully installed HTML::Mason version 1.22.

Should future versions of mod_perl 1 include
a note for perl 5.6.1 AIX users to build with APACI_ARGS='
--enable-module=so'
if they want to build Apache::Request ?

Or maybe it should be a question/warning when running Makefile.PL ?

However, If it's the only solution for perl 5.6.1,
it should be documented at least in the installation Documentation
for mod_perl1, libapreq1 and HTML::Mason.

If you think it's a good idea, I'm ready to contribute patches.

Regards

José


Mime
View raw message