httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: libapreq failures with 1.2 and Mac OS X Server
Date Wed, 13 Aug 2003 19:03:46 GMT
David Wheeler wrote:
> On Friday, August 8, 2003, at 11:42  AM, Stas Bekman wrote:
> 
>>>> Oh, yes, I found that I always have to compile Apache 1.3.28 on Mac 
>>>> OS X --without-execstrip. Not sure why.
>>>
>>> Sounds like a bug in the apache build to me. Ask at the httpd-dev list?
>>>
>>>> It's in my articles, though.
>>>
>>>  >
>>>
>>>>   http://www.macdevcenter.com/pub/a/mac/2002/11/05/apache_osx.html
>>>
>>> However it's not in INSTALL.MacOSX, can you please post a patch? 
>>> Perhaps that file needs more syncing with your online article?
>>
>>
>> Ah, I haven't realized that this is a modperl issue. Do/should we have 
>> INSTALL.MACOSX for modperl 1.0 that will say that? So you can maintain 
>> it on the perl.apache.org site, like we have for win32?
>> http://perl.apache.org/docs/1.0/os/index.html
> 
> 
> I'm not sure it's a mod_perl issue. Could it be an Apache issue? Either 
> way, it seems to me as if there could be a hint to the compiler to 
> always use --without-execstrip on Mac OS X. I just don't know where it 
> goes, with mod_perl or with Apache.

That should be possible, care to offer a patch? If not we should add it to the 
STATUS file and hopefull someone will do that.

In any case, can you please ask httpd-dev whether this should be fixed in httpd?

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message