httpd-apreq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: libapreq failures with 1.2 and Mac OS X Server
Date Fri, 08 Aug 2003 15:53:51 GMT
Chris Nandor wrote:
> I've had success building libapreq on Mac OS X, but not so far on a Mac OS
> X Server box.
> 
> Environment:
>   Mac OS X Server 10.2.6
>   perl 5.8.1 RC4
>   Apache 1.3.28 in /usr/local
>   mod_perl 1.28 in /usr/local
>   libapreq 1.2
> 
> Commands:
>   ./configure --with-apache-include=/usr/local/apache/include/
>   make
>   make install
>   perl Makefile.PL -httpd /usr/local/apache/sbin/httpd
>   make
>   make test
> 
> All tests fail.
> 
> Contents of t/logs/error_log:
>   dyld: /usr/local/apache/sbin/httpd Undefined symbols:
>   _ap_pstrndup
>   _ap_push_array
>   _perl_request_rec
>   _sv2request_rec
> 
> Any thoughts?  I've googled around for answers, I've tried different
> permutations of my setup, but nothing works.  I get only those four
> undefined symbols.  Thanks,

Does Mac OS X uses .exp files? I can't see your compilation log, but if it 
does, it probably uses apaci/mod_perl.exp, which defines sv2request_rec and 
perl_request_rec (my guess is that the _ prefix is just an internal thing).



__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message